zero-ml
Status
Back
Maintenance
Server Upgrade
Completed 14 Aug at 02:32pm IDT.
Affected services
zero-ml.com
Completed
Server upgrade completed successfully
Posted 14 Aug at 02:32pm IDT.
Started
Upgrading to a new server
Posted 14 Aug at 02:00pm IDT.